The official blog of the Saved Content site

The aim of this blog is to collect and archive my selected thoughts, ideas, feelings, reactions, and opinions on subject matters that pique my interest. These entries represent initial drafts that may contain grammatical and spelling errors and whose substance and position could still change, and which, at some point, I could decide to put together into in-depth articles that will be posted on the main Saved Content and Poverty Sucks sites.

"God save us all from that evil Satanic Nazi, Paypal."

Gadget

This content is not yet available over encrypted connections.

TCP/IP Not Working and Missing Settings on LAN Interface

My Desktop/Storage PC went down during a power outage.  After power was restored, I found that I couldn't surf the Internet.  I checked the LAN interface in Network Connections and found that it didn't have any TCP/IP values.  Usually, they have at least 0.0.0.0 as its IP and Subnet Mask but in this case, it was just blank.

I tried disabling and repairing the LAN network connection but its TCP/IP values were still blank.  After I tried repairing the connection, I got this message - "Failed to query TCP/IP settings for the connection."  I also tried disabling and enabling the IPX/SPX and TCP/IP protocols and then tried removing them but all that didn't work.

After a bit of research, I uninstalled all my Network adapters in Device Manager and rebooted.  My network adapter was immediately detected again after startup.  This fixed my LAN network connection and I was able to surf again.

Gadget

This content is not yet available over encrypted connections.